
  



<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.nwnews.com/content/tncms/live/" />
<meta name="keywords" content="opinion" />
<meta name="news_keywords" content="opinion" />
<meta name="description" content="Editor," />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/977b0d42-992c-11ea-b9dc-7bba8052552d.png" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Letter: Trader Joe's joke 'vent' too far" />
<meta property="og:description" content="Editor," />
<meta property="og:site_name" content="The Woodinville Weekly" />
<meta property="og:section" content="Opinion" />
<meta property="article:publisher" content="https://www.facebook.com/wdvlweekly/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@WdvlWeekly" />
<meta property="tncms:subs" content="2.0" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.78b0163131a0eb95aef899d56f817c34.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0740431ec2aa31f2e7d813ea5c660a8d.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css2?family=Barlow+Semi+Condensed:wght@400;700&amp;family=Barlow:wght@400;700&amp;display=swap"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.a78f8be1f6e0dabcb5acb9a8939501f8.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/opinion","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":536},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "3922,4157,4167,4156,4119", "prefix": ""}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/impressions.js?_dc=1617896131"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/traffic.js?_dc=1617863729"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/settings.js?_dc=1595967393"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>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</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/fixed-big-ad-top-asset/1.js?_dc=1617624064"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/fixed-big-ad-middle-asset/1.js?_dc=1617624064"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/fixed-big-ad-bottom-asset/1.js?_dc=1617624064"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1617624064"></script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311","asset_id":"5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca","title":"What\\'s your favorite type of Girl Scout cookie?","url":"\/whats-your-favorite-type-of-girl-scout-cookie\/poll_5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca.html","results":"https:\/\/www.nwnews.com\/whats-your-favorite-type-of-girl-scout-cookie\/poll_5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca.html?action=poll:results&format=json","chart":"bar"}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1617624064"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script>/*<![CDATA[*/ window.bulletins_config || (window.bulletins_config = []); window.bulletins_config.push({"columns":"2","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","bottom_margin":"standard","asset_title":"hover","block_bg_color":"","bg_color":"","block_id":"914307"}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/fixed-big-ad-bottom/1.js?_dc=1617624064"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/ads/fixed-impact-bottom/1.js?_dc=1617278468"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Letter: Trader Joe's joke 'vent' too far | Opinion | nwnews.com</title>
            
    <style>body { background-color: #ffffff; color: #000; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #368740; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #ffffff; } .fixed-nav #main-navigation { background-color: #ffffff !important; } #site-top-nav-container, #site-top-nav { background-color: #F1F1F1; } #site-footer-container, #site-footer { background-color: #368740; color: #000; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #000000; } .navbar-toggle .icon-bar { background-color: #000000 !important; } .navbar-toggle .sr-only-show { color: #000000 !important; } #site-top-nav .list-inline>li>a { color: #000000; } .asset .asset-body p, .asset #asset-content p { color: #000; } #site-header-container { background-color: #FFF; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #000000; } }#site-top-nav .list-inline>li>a.btn:not(.btn-link) { color: #fff; }#site-copyright a, #site-footer a { color: #FFF; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #ffffff; }#site-header-container{ border-bottom: 3px solid #ffffff; }#site-footer-container{ border-top: 3px solid #ffffff; } .tnt-bg-accent { background-color: #ffffff; } a .tnt-caret-down { color: #ffffff; } .block-title .block-title-inner { border-color: #ffffff; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #ffffff; } .form-control:focus { border-bottom-color: #ffffff; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ body { font-family: 'Barlow'; } strong, b { font-weight: 700; } h1, h2, h3, h4, h5, h6, .tnt-headline { font-family: 'Barlow Semi Condensed'; font-weight: 700; } /* START OF CUSTOM CSS */ .padding-top { padding-top: 45px; } /* START OF HTML BLOCKS */ /* END OF HTML BLOCKS */ /* END OF CUSTOM CSS */ /* START OF HEADER */ /* START OF TOP BAR */ /* END OF TOP BAR */ /* START OF MASTHEAD */ /* END OF MASTHEAD */ /* START OF WEATHER WIDGET */ /* END OF WEATHER WIDGET */ /* START OF SEARCH WIDGET */ /* END OF SEARCH WIDGET */ /* END OF HEADER */ /* START OF NAVIGATION */ /* START OF MOBILE NAVIGATION */ /* END OF MOBILE NAVIGATION */ /*END OF NAVIGATION */ /* START OF BLOCKS */ .featuredStyled .card-body { width: 75%; margin: 0 auto; text-align: center; position: absolute; left: 12%; background: white; padding: 15px; } .featuredStyled .showcase .card-body { bottom: -40px; } .featuredStyled .card-grid .card-body { top: 150px; } .featuredStyled .card .card-label-section { float: left; } .featuredStyled .card .card-label-flags { float: right; } .featuredStyled .card-grid .card-body { padding: 15px !important; } .block-title-inner{position:relative;top: 1.9rem;;background:#368740;color:#FFF;padding: 5px 10px!important} .block-title{border-bottom:2px solid #368740;position:relative;top:-2rem;text-transform:uppercase} .block-title .block-title-inner{border-color:transparent} .block-title{text-align:center} .notCentered .block-title {text-align:left} .block-title a { color: #FFF; } .block-title a:hover { text-decoration: none; } #block-914329 .block-title { text-align: initial; position: initial; top: initial; border-top: 2px solid #368740; border-right: 2px solid #368740; background: #F1F1F1; } .breadcrumb { padding-right: 15px; } #block-914329 .block-title .block-title-inner { position: inherit; } #tncms-region-index-primary-middle, #tncms-region-index-secondary-middle { margin-top: 60px; } #tncms-region-front-full-top { margin-bottom: 70px; } a:hover { color: #000; } .block-title h4 { color: rgba(255,255,255,.7); } #site-header-container { border-bottom: none; } h2 .small { color: rgba(255,255,255,0.5); } .comments-control-panel h3 { display: none; } .comment-rules:before { content: "Sign up for your Weekly newsletter"; display: block; font-size: 24px; font-weight: 700; padding-bottom: 10px; } .tnt-headline a { color: #000; } /* START OF OBITUARIES */ /* END OF OBITUARIES */ /* END OF BLOCKS */ /* START OF ARTICLES */ /* END OF ARTICLES */ /* START OF FOOTER */ /* START OF COPYRIGHT */ /* START OF COPYRIGHT */ /* END OF FOOTER */ /* START OF ADOWL */ .adowl-default .block-title { margin-top: 34px; } /* END OF ADOWL */ </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.nwnews.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Letter: Trader Joe's joke 'vent' too far | Opinion | nwnews.com" href="http://www.nwnews.com/search/?f=rss&amp;t=article&amp;c=opinion&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            
    
    

        </head>
        <body class="app-editorial grid-mobile-pattern blox-asset uuid-7cbe4a58-97f2-11eb-8eaa-03b8e90af65f  section-opinion type-article infinity-disabled" data-path="/opinion">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.nwnews.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=mobile_pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Fopinion&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=blox&amp;tncms.system.render_time=536&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.asset.id=7cbe4a58-97f2-11eb-8eaa-03b8e90af65f&amp;tncms.asset.app=editorial&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.nwnews.com",
  secureDomain: "nwnews.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        
        <script>
            document.addEventListener("DOMContentLoaded", function(event) {
                __tnt.metering.access.d.push(function(){
                    //DMP logging
                    if(window._cc){
                        __tnt.log("Logging DMP data")
                        var paywallDmpData = 'Paywall : Viewed Paywall';
                        // Call to cms.dmp.js_behavior_action is here
                        
                    }
                });
            });
        </script>
    

    <div id="template-metering" data-message-mode="extended">
    <template class="template meter subscription">
        <div class="meter message" data-message="blox subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for reading!

                </h4>
                <p>Please <span class="not-logged-in">log in, or sign up for a new account and</span> purchase a subscription to continue reading.</p>

                <div class="col-xs-12">
                    <div class="row not-logged-in">

                        <div class="col-xs-6">
                            
    <a  class="btn btn-default btn-block" href="https://www.nwnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Sign Up</a>
                        </div>
                        <div class="col-xs-6">
                            
    <a class="btn btn-primary btn-block" href="https://www.nwnews.com/users/login/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Log In</a>
                        </div>
                    </div>
                    <div class="row logged-in">
                        <div class="pull-right">
                            <a class="btn btn-default meter-modal-open">Purchase a Subscription
</a>
                        </div>
                    </div>
                    </div>
            </div>
        </div>
        </div>
    
    
</template>
    
    <template class="template meter registration">
        
    <div class="meter message wall panel panel-default" data-message="blox registration wall">
        <div class="panel-body">
            <h4 class="meter-heading media-heading">
                Thank you for reading!

            </h4>
            <p>Please <span class="not-logged-in">log in, or sign up for a new account</span> to continue reading.</p>

            <div class="col-xs-12">
                <div class="row not-logged-in">
                
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="https://www.nwnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://www.nwnews.com/users/login/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Log In</a>
                    </div>
                </div>
                
                <div class="row logged-in">
                    <a class="btn btn-default" href="https://www.nwnews.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.nwnews.com%252Fopinion%252Fletter-trader-joes-joke-vent-too-far%252Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Purchase a Subscription
</a>
                </div>
            </div>
        </div>
    </div>
</template>
    
    <template class="template meter referred">
        <div class="meter notification referred alert alert-dismissable alert-info" data-message="blox user referred">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
         
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
    
    <template class="template meter access" data-count="1">
        <div class="meter notification access alert alert-dismissable alert-info hidden-print" data-message="blox first free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
         
        <p><strong>Welcome!</strong> We hope that you enjoy our free content.</p>
    </div>
</template>
    
    <template class="template meter access" data-count="3" data-registered="false">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox login prompt">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <a class="alert-link" href="https://www.nwnews.com/users/login/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">log in</a> or <a class="alert-link" href="https://www.nwnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">create an account</a> to continue reading.</p>
        </div>
</template>
    
    <template class="template meter access" data-count="5">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox last free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <span class="not-logged-in"><a class="alert-link" href="https://www.nwnews.com/users/login/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">log in</a> to your subscriber account or <a class="alert-link" href="https://www.nwnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">create an account</a> and subscribe</span><span class="logged-in"><a href="https://www.nwnews.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.nwnews.com%252Fopinion%252Fletter-trader-joes-joke-vent-too-far%252Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">purchase a subscription</a></span> to continue reading.</p>
    </div>
</template>
    
    <template class="template meter access" data-registered="true" data-after-wall="true">
        <div class="meter notification alert alert-dismissable alert-info" data-message="blox after login">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for signing in!</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    <template class="template meter access" data-count="2" data-registered="false">
        <div class="meter notification access alert alert-dismissable alert-info hidden-print" data-message="blox two before login">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>

</template>
    
    <template class="template meter access" data-count="1" data-registered="false">
       <div class="meter notification access alert alert-dismissable alert-info hidden-print" data-message="blox three before login">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>

</template>

    <template class="template meter access" data-count="4">
       <div class="meter notification access alert alert-dismissable alert-info hidden-print" data-message="blox two before subscription">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>

</template>
    
    <template class="template meter access" data-count="3">
       <div class="meter notification access alert alert-dismissable alert-info hidden-print" data-message="blox three before subscription">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>

</template>
    
<div id="subscription-modal" class="subscription metering-modal modal fade" data-message="blox modal subscription">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="modal-title">Thank you for reading!
</h4>
            </div>

            <div class="modal-body">
                <div class="row">
                    <div class="col-xs-12">
                    <div class="not-logged-in">
                            <p>Please log in, or sign up for a new account and purchase a subscription to continue reading.
</p>
                        </div>
            
                        <div class="logged-in">
                            <div class="no-services" style="display:none">
                                <p>Please purchase a subscription to continue reading.
</p>
                            </div>
                
                            <div class="has-services" style="display:none">
                                <p>Your current subscription does not provide access to this content.
</p>
                            </div>
                        </div>

                        <div class="col-xs-12">
                            <div class="row not-logged-in padding-bottom">
                                <div class="col-xs-6">
                                    
    <a  class="btn btn-default btn-block" href="https://www.nwnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Sign Up</a>
                                </div>
                                <div class="col-xs-6">
                                    
    <a class="btn btn-primary btn-block" href="https://www.nwnews.com/users/login/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Log In</a>
                                </div>
                            </div>
                        </div>
                    <div class="col-xs-12">
                            </div>
                        
                        <div class="col-xs-12 logged-in">
                            <div class="subscription-services">
    <script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[3922] = {
    'name':'Print & Digital Subscription',
    'id':'3922',
    'prices':['3999','5999'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<div data-service-id="3922" class="subscription-service panel panel-default subscription-service-digital ">
        <div class="panel-heading service-heading">
            <h3 class="panel-title">Print & Digital Subscription</h3>
        </div>
        <div class="panel-body">
            
            
            <div class="service-desc">
                <h3>For new subscribers or renewals</h3>
<p>Sign up and receive 52 weeks of <strong>The Woodinville Weekly</strong> <strong>print newspaper</strong> delivery to your mailbox, unlimited access to digital content and a weekly e-edition.</p>
            </div>
            <div class="row row-eq-height">
                
                <div class="col-sm-6 align-bottom">
                    <div class="service-rates">
                        
                            <span class="text-muted">Starting at</span><div class="service-price-text">
                                    $39.99
                                    
                                        
for 365 days

                                    
                                </div>
                            
                        
                    </div>
                </div>
                <div class="col-sm-6 align-bottom">
                        <div class="service-sublink">
                            <a data-subscription-service="3922" data-subscription-service-zipcodes="" class="btn btn-primary pull-right" href="https://www.nwnews.com/users/admin/service/purchase/?serviceid=3922&referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Get Started</a>
                        </div>
                    
                </div>
                
            </div>
        </div>
        
            <div class="panel-footer">
                <div class="view-rates-container">
                    <a class="view-rates-link" data-toggle="collapse" href="#collapse-rates-3922">
                        <span class="view-rates-text">View all rates</span> <i class="fas tnt-caret-down"></i>
                    </a>
                </div>
                <div id="collapse-rates-3922" class="collapse collapse-rates">
                    <table class="table table-striped table-condensed">
                        <thead>
                            <tr>
                                <th>Rate</th>
                                <th>Price</th>
                                <th>Duration</th>
                            </tr>
                        </thead>
                        <tbody>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">1 year (Woodinville zip code)</td>
                                    <td class="service-rate-cell-price">
                                        $39.99
                                    </td>
                                    <td class="service-rate-cell-duration">
for 365 days
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">1 year (outside of Woodinville)</td>
                                    <td class="service-rate-cell-price">
                                        $59.99
                                    </td>
                                    <td class="service-rate-cell-duration">
for 365 days
</td>
                                </tr>
                            
                        </tbody>
                    </table>
                </div>
            </div>
        
    </div><script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[4157] = {
    'name':'4-week Trial Subscription',
    'id':'4157',
    'prices':['499'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<div data-service-id="4157" class="subscription-service panel panel-default subscription-service-digital ">
        <div class="panel-heading service-heading">
            <h3 class="panel-title">4-week Trial Subscription</h3>
        </div>
        <div class="panel-body">
            
            
            <div class="service-desc">
                <p>Sign up for a 4-week trial subscription and you'll receive 4 weeks of The Woodinville Weekly print newspaper delivered to your mailbox, unlimited digital access and a weekly e-edition.</p>
            </div>
            <div class="row row-eq-height">
                
                <div class="col-sm-6 align-bottom">
                    <div class="service-rates">
                        
                            <div class="service-price-text">
                                    $4.99
                                    
                                        
for 30 days

                                    
                                </div>
                            
                        
                    </div>
                </div>
                <div class="col-sm-6 align-bottom">
                        <div class="service-sublink">
                            <a data-subscription-service="4157" data-subscription-service-zipcodes="" class="btn btn-primary pull-right" href="https://www.nwnews.com/users/admin/service/purchase/?serviceid=4157&referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Get Started</a>
                        </div>
                    
                </div>
                
            </div>
        </div>
        
    </div><script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[4167] = {
    'name':'Business Membership',
    'id':'4167',
    'prices':['5000','10000'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<div data-service-id="4167" class="subscription-service panel panel-default subscription-service-digital ">
        <div class="panel-heading service-heading">
            <h3 class="panel-title">Business Membership</h3>
        </div>
        <div class="panel-body">
            
            
            <div class="service-desc">
                <p>Business members receive a weekly newspaper, copies for their customers, full color advertising inches, free classifieds and between 25% to 50% off additional advertising.</p>
            </div>
            <div class="row row-eq-height">
                
                <div class="col-sm-6 align-bottom">
                    <div class="service-rates">
                        
                            <span class="text-muted">Starting at</span><div class="service-price-text">
                                    $50.00
                                    
                                        
for 30 days

                                    
                                </div>
                            
                        
                    </div>
                </div>
                <div class="col-sm-6 align-bottom">
                        <div class="service-sublink">
                            <a data-subscription-service="4167" data-subscription-service-zipcodes="" class="btn btn-primary pull-right" href="https://www.nwnews.com/users/admin/service/purchase/?serviceid=4167&referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Get Started</a>
                        </div>
                    
                </div>
                
            </div>
        </div>
        
            <div class="panel-footer">
                <div class="view-rates-container">
                    <a class="view-rates-link" data-toggle="collapse" href="#collapse-rates-4167">
                        <span class="view-rates-text">View all rates</span> <i class="fas tnt-caret-down"></i>
                    </a>
                </div>
                <div id="collapse-rates-4167" class="collapse collapse-rates">
                    <table class="table table-striped table-condensed">
                        <thead>
                            <tr>
                                <th>Rate</th>
                                <th>Price</th>
                                <th>Duration</th>
                            </tr>
                        </thead>
                        <tbody>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">Small Business Membership</td>
                                    <td class="service-rate-cell-price">
                                        $50.00
                                    </td>
                                    <td class="service-rate-cell-duration">
for 30 days
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">Business Membership</td>
                                    <td class="service-rate-cell-price">
                                        $100.00
                                    </td>
                                    <td class="service-rate-cell-duration">
for 30 days
</td>
                                </tr>
                            
                        </tbody>
                    </table>
                </div>
            </div>
        
    </div><script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[4156] = {
    'name':'Digital Only Subscription',
    'id':'4156',
    'prices':['1599','199'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<div data-service-id="4156" class="subscription-service panel panel-default subscription-service-digital ">
        <div class="panel-heading service-heading">
            <h3 class="panel-title">Digital Only Subscription</h3>
        </div>
        <div class="panel-body">
            
            
            <div class="service-desc">
                <p>Sign up and receive 52 weeks of unlimited digital access, including a weekly e-edition of The Woodinville Weekly.</p>
            </div>
            <div class="row row-eq-height">
                
                <div class="col-sm-6 align-bottom">
                    <div class="service-rates">
                        
                            <span class="text-muted">Starting at</span><div class="service-price-text">
                                    $15.99
                                    
                                        
for 365 days

                                    
                                </div>
                            
                        
                    </div>
                </div>
                <div class="col-sm-6 align-bottom">
                        <div class="service-sublink">
                            <a data-subscription-service="4156" data-subscription-service-zipcodes="" class="btn btn-primary pull-right" href="https://www.nwnews.com/users/admin/service/purchase/?serviceid=4156&referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Get Started</a>
                        </div>
                    
                </div>
                
            </div>
        </div>
        
            <div class="panel-footer">
                <div class="view-rates-container">
                    <a class="view-rates-link" data-toggle="collapse" href="#collapse-rates-4156">
                        <span class="view-rates-text">View all rates</span> <i class="fas tnt-caret-down"></i>
                    </a>
                </div>
                <div id="collapse-rates-4156" class="collapse collapse-rates">
                    <table class="table table-striped table-condensed">
                        <thead>
                            <tr>
                                <th>Rate</th>
                                <th>Price</th>
                                <th>Duration</th>
                            </tr>
                        </thead>
                        <tbody>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">Digital Only</td>
                                    <td class="service-rate-cell-price">
                                        $15.99
                                    </td>
                                    <td class="service-rate-cell-duration">
for 365 days
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">Digital only (1 month trial)</td>
                                    <td class="service-rate-cell-price">
                                        $1.99
                                    </td>
                                    <td class="service-rate-cell-duration">
for 30 days
</td>
                                </tr>
                            
                        </tbody>
                    </table>
                </div>
            </div>
        
    </div><script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[4119] = {
    'name':'Print Subscriber Access',
    'id':'4119',
    'prices':[''],
    'brand':'delimited',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<div data-service-id="4119" class="subscription-service panel panel-default subscription-service-digital ">
        <div class="panel-heading service-heading">
            <h3 class="panel-title">Print Subscriber Access</h3>
        </div>
        <div class="panel-body">
            
            
            <div class="service-desc">
                <p>If you're a print subscriber, this is how you gain access to your online content.</p>
            </div>
            <div class="row row-eq-height">
                
                <div class="col-sm-6 align-bottom">
                    <div class="service-rates">
                        
                            
                                <div class="service-price-text">
                                    Free
                                    
                                </div>
                            
                        
                    </div>
                </div>
                <div class="col-sm-6 align-bottom">
                        <div class="service-sublink">
                            <a data-subscription-service="4119" data-subscription-service-zipcodes="" class="btn btn-primary pull-right" href="https://www.nwnews.com/users/admin/service/purchase/?serviceid=4119&referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Get Started</a>
                        </div>
                    
                </div>
                
            </div>
        </div>
        
    </div>

    
</div>

<script>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</script>

</div>
                        
                    </div>
                </div>
            </div>
            <div class="modal-footer">
                <div class="logged-in">
                <form id="service-promo-open" class="text-left service-promo-open" method="post" action="">
    <input type="hidden" name="serviceid" value=""/>
    <div class="form-group">
        <label for="promo">Have a promo code?</label>
    </div>
    
    <div class="form-group">
        <div class="input-group">
        <input type="text" class="form-control" name="promo" placeholder="Enter Code" value=""/>
        <span class="input-group-btn">
        <button type="submit" class="btn btn-primary">Find Offers</button>
        </span>
        </div>
    </div>
</form>
                </div>
                
            </div>
        </div>
    </div>
</div>

<script>
var promoOpenedFromModal = false;
$(function(){
    $('#service-promo-open').on('submit',function(){
    
        if($('#service-promo-open').find('input[name=promo]').val()!=""){
            $('#service-promo-modal').find('input[name=promo]').val($('#service-promo-open').find('input[name=promo]').val());
            $('#service-promo-modal').find('.promo-loading').show();
    
            if($('#subscription-modal').is(':visible')){
                $('#subscription-modal').modal('toggle');
                promoOpenedFromModal = true;
                setTimeout(function () {
                    $('#service-promo-modal').find('.modal').modal('toggle').submit();
                },500);
            }else{
                $('#service-promo-modal').find('.modal').modal('toggle').submit();
            }
       }
    
        return false;
    });
    
    if($("#service-promo-open").find("input[name=promo]").val()!=""){
        setTimeout(function () {
            $("#service-promo-open").find("button").click();
        },500);
    }
    
});
</script>

<form id="service-promo-modal" class="" method="post" action="https://www.nwnews.com/content/tncms/live/" data-endpoint="https://www.nwnews.com/tncms/subscription/services/?promoCode=">
    <input type="hidden" name="serviceid" value=""/>
    <input type="hidden" name="referer_url" value="/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"/>

    <div class="modal fade">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
                    <div class="form-group">
                        <label class="" for="promo">Have a promo code?</label>
                    </div>
                    <div class="form-group">
                        <div class="input-group">
                            <input type="text" class="form-control" name="promo" placeholder="Enter Code" value="">
                            <span class="input-group-btn"><button type="submit" class="btn btn-primary">Find Offers</button></span>
                        </div>
                    </div>
                </div>
                <div class="modal-body">
                    <template class="template promo-not-found-template">
                        <div class="promo-not-found-warning alert alert-warning">
    <p><strong>Sorry</strong>, no promotional deals were found matching that code.</p>
</div></template>
                    <template class="template promo-found-message-template">
                        <div class="promo-found-message alert alert-success clearfix">
    <p><strong>Promotional Rates</strong> were found for your code.
    
    </p>
</div></template>
                    <template class="template promo-error-template">
                        <div class="promo-error alert alert-warning">
    <p><strong>Sorry</strong>, an error occurred.</p>
</div></template>
                    
                    <div class="row">
                    <h2 class="promo-loading text-center font-larger" style="display:none;"><span class="fas tnt-spinner tnt-spin"></span></h2><div class="col-xs-12 service-promo-status-message"></div>
                    <div class="col-xs-12 output"></div>
                    </div>
                    
                    <template class="template-promo-service hide">
                        <div class="promotion-service subscription-service panel panel-default">
                            <h3 class="panel-heading"></h3>
                            <div class="panel-body">
                                <div class="service-note alert alert-info"></div>
                                <p class="description"></p>
                                <div class="rate-output"><p class="hide">do not remove</p></div>
                            </div>
                        </div>
                    </template>
                    <template class="template-promo-rate hide">
                        <div class="promotion subscription-service panel panel-default">
                            <div class="panel-body">
                                <h4 class="rate-name"></h4>
                                <div class="clearfix">
                                    <span class="pull-left">
                                        <div class="terms-automatic">
                                            <strong><span class="price"></span> <span class="duration"></span></strong>
                                            <small class="fine-print"></small>
                                        </div>
                                        <div class="terms-manual"></div>
                                    </span>
                                    <a data-subscription-service="" class="pull-right btn btn-primary rate-link">Get Started</a>
                                </div>
                            </div>
                        </div>
                    </template>

                </div>
                <div class="modal-footer">
                    <button type="button" class="btn btn-default pull-left" data-dismiss="modal">Back</button>
                </div>
            </div>
        </div>
    </div>
</form><script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[3922] = {
    'name':'Print & Digital Subscription',
    'id':'3922',
    'prices':['3999','5999'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[4157] = {
    'name':'4-week Trial Subscription',
    'id':'4157',
    'prices':['499'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[4167] = {
    'name':'Business Membership',
    'id':'4167',
    'prices':['5000','10000'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[4156] = {
    'name':'Digital Only Subscription',
    'id':'4156',
    'prices':['1599','199'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[4119] = {
    'name':'Print Subscriber Access',
    'id':'4119',
    'prices':[''],
    'brand':'delimited',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<script>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</script><script>

    $(function(){
        $('#service-promo-modal').on('submit',function(){
            var promoEl = $('#service-promo-modal');
            var promoVal = promoEl.find('input[name=promo]').val();
        
            __tnt.subscription.promos.fetch(promoEl, promoVal);
            
            $("#service-promo-modal").find("[data-dismiss=modal]").on('click',function(){
                if(promoOpenedFromModal){ 
                    $("#template-metering").find('.metering-modal').first().modal();
                    promoOpenedFromModal = true;
                }
            });

            return false;
        });
    });
</script>

<script>
    $(function(){
        var i = 0;
        $('#subscription-modal').find('.subscription-services').find('.subscription-service').each(function(){
            $(this).attr('id','service-tab-'+i);
        
            $(this).find('.panel-heading h3').html('<a href="" data-toggle="collapse" data-parent="services-modal-collapsable-tabs" aria-expanded="false" aria-controls="service-tab-'+i+'">'+$(this).find('.panel-heading h3').text()+'</a>')
            $(this).find('.panel-body').addClass('panel-collapse collapse').attr('role','tabpanel');
            
            if(i==0){
                $(this).find('.panel-collapse').collapse('show');
                $(this).find('.panel-footer').show();
            }else{
                $(this).find('.panel-footer').hide();
            }
        
            i++;
        });
    
        $('.subscription-services-filter').hide();
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').css({'padding':'0px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a').css({'display':'block','padding':'10px 15px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a[data-toggle=collapse]').on('click',function(event){
            var id = $(this).attr('aria-controls');
            var open = $('#'+id).find('.collapse').hasClass('in');
            
            $('#subscription-modal').find('.subscription-services .subscription-service').each(function(){
                if(this.id == id){
                    $(this).find('.panel-collapse').collapse('show');
                    $(this).find('.panel-footer').show();
                }else{
                    $(this).find('.panel-collapse').collapse('hide');
                    $(this).find('.panel-footer').hide();
                }
            });
        });
        
        $('#asset-content').find('.subscription-required').find('.panel-footer').find('a[data-toggle=collapse]').on('click',function(event){
            $(this).parents('.panel-footer').find('.collapse.collapse-rates').collapse('toggle');
        });
        
        
        $('#asset-content').find('.meter-modal-open').on('click',function(){
            $('#asset-content').find('.alert.notification').css({'z-index':'900'});
            $("#template-metering").find('.metering-modal').first().modal();
        
        });
        
        $('#eedition-subscription').find('.meter-modal-open').on('click',function(){
            $("#template-metering").find('.metering-modal').first().modal();
        });
    });
    
</script>

    
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(3922);
                
                bloxServiceIDs.push(4157);
                
                bloxServiceIDs.push(4167);
                
                bloxServiceIDs.push(4156);
                
                bloxServiceIDs.push(4119);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/opinion","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.nwnews.com/tncms/admin/editorial-asset/?edit=7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-914363" class="tncms-block hidden-md hidden-lg"><div id="user-controls-914363" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.nwnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.nwnews.com/users/login/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.nwnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-914363').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.nwnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.nwnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.nwnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-914363').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.nwnews.com/users/logout/" id="user-logout-form-914363"><input type="hidden" name="referer_url" value="https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/local/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/regional/"  class="nav-link tnt-section-regional">Regional</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/state/"  class="nav-link tnt-section-state">State</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/this_week/"  class="nav-link tnt-section-this-week">This Week</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/eat_sip_shop/"  class="nav-link tnt-section-eat-sip-shop">Eat, Sip, Shop</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/real_estate/"  class="nav-link tnt-section-real-estate">Real Estate</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/senior_living/"  class="nav-link tnt-section-senior-living">Senior Living</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/multimedia/"  class="nav-link tnt-section-multimedia">Multimedia</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/multimedia/photo_galleries/"  class="nav-link tnt-section-photo-galleries">Photo Galleries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/multimedia/video_gallery/"  class="nav-link tnt-section-videos">Videos</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/eedition/"  class="nav-link tnt-section-e-edition">e-Edition</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/housing/sale"  class="nav-link tnt-section-real-estate">Real Estate</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/housing/rent"  class="nav-link tnt-section-property-for-rent">Property For Rent</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/vehicle"  class="nav-link tnt-section-cars-vehicles">Cars & Vehicles</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/job"  class="nav-link tnt-section-jobs">Jobs</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/sale"  class="nav-link tnt-section-items-for-sale">Items For Sale</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/sale/pet"  class="nav-link tnt-section-pets">Pets</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/sale/sale"  class="nav-link tnt-section-auctions-estate-garage-sales">Auctions, Estate & Garage Sales</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/service"  class="nav-link tnt-section-services">Services</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/community"  class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/personals"  class="nav-link tnt-section-personals">Personals</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/place_an_ad/"  class="nav-link tnt-section-place-an-ad">Place an Ad</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services"  class="nav-link tnt-section-subscribe">Subscribe</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/valley_view/"  class="nav-link tnt-section-valley-view">Valley View</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/cops_and_courts/"  class="nav-link tnt-section-cops-and-courts">Cops and Courts</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-914359" class="tncms-block hidden-md hidden-lg"><ul id="site-search-914359-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-914359" aria-labelledby="site-search-button-914359" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal ">
        <input id="site-search-914359-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-914359-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-914359" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-914359-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-914359').submit();
        return false;
    });

    $('#site-search-914359').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-914359 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-914359 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-914359-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-914362" class="tncms-block"><div id="user-controls-914362" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.nwnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.nwnews.com/users/login/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.nwnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-914362').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.nwnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.nwnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.nwnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-914362').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.nwnews.com/users/logout/" id="user-logout-form-914362"><input type="hidden" name="referer_url" value="https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-914360" class="tncms-block"><div class="follow-links-914360 pull-right">
    
    <section id="block-914360" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/wdvlweekly/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/WdvlWeekly" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.linkedin.com/showcase/woodinvilleweekly/" title="LinkedIn" target="_blank" rel="noopener" class="btn btn-md btn-link li" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-linkedin-in"></i>
                    <span class="sr-only">LinkedIn</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.nwnews.com",
  "sameAs" : ["https://www.facebook.com/wdvlweekly/","https://twitter.com/WdvlWeekly","https://www.linkedin.com/showcase/woodinvilleweekly/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-914327" class="tncms-block"><div id="site-logo-914327" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/e26c596a-1545-11eb-a3d1-cf31d0c8412e.png?resize=200%2C104" 
            srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/e26c596a-1545-11eb-a3d1-cf31d0c8412e.png?resize=150%2C78 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/e26c596a-1545-11eb-a3d1-cf31d0c8412e.png?resize=200%2C104 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/e26c596a-1545-11eb-a3d1-cf31d0c8412e.png?resize=225%2C117 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/e26c596a-1545-11eb-a3d1-cf31d0c8412e.png?resize=300%2C155 300w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/e26c596a-1545-11eb-a3d1-cf31d0c8412e.png 400w"
            sizes="(min-width: 1200px) 380px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="336"
            height="174"
            alt="site-logo"></a>
        </div></div></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-914364" class="tncms-block padding-top"><div id="weather-914364" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=98072" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-cloudy"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">38&deg;</span>
                    
                        <span class="cond">Mostly Cloudy <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="98072"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-914364 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Woodinville, WA
                                
                                 <small>(98072)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Sun and clouds mixed. High 52F. Winds light and variable..</p>
                            <h5>Tonight</h5>
                            <p>Partly to mostly cloudy. Low around 35F. Winds light and variable.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: April 8, 2021 @ 9:51 am</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=98072"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-914358" class="tncms-block"><section id="block-914358" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-914358" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-914358" aria-labelledby="site-search-button-914358" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal form-control">
        <input id="site-search-914358-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-914358-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-914358-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-914358').submit();
        return false;
    });

    $('#site-search-914358').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-914358 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-914358 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-914358-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-914355" class="tncms-block"><div id="site-logo-914355" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/51d40d9c-9932-11ea-b9dc-b3daf9d7cdce.jpg?resize=200%2C104" 
            srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/51d40d9c-9932-11ea-b9dc-b3daf9d7cdce.jpg?resize=150%2C78 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/51d40d9c-9932-11ea-b9dc-b3daf9d7cdce.jpg?resize=200%2C104 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/51d40d9c-9932-11ea-b9dc-b3daf9d7cdce.jpg?resize=225%2C117 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/51d40d9c-9932-11ea-b9dc-b3daf9d7cdce.jpg?resize=300%2C156 300w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/51d40d9c-9932-11ea-b9dc-b3daf9d7cdce.jpg?resize=400%2C208 400w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/51d40d9c-9932-11ea-b9dc-b3daf9d7cdce.jpg?resize=540%2C281 540w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/51d40d9c-9932-11ea-b9dc-b3daf9d7cdce.jpg?resize=640%2C333 640w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/51d40d9c-9932-11ea-b9dc-b3daf9d7cdce.jpg 750w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="700"
            height="364"
            alt="site-logo"></a>
        </div></div></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li class="dropdown" aria-expanded="false">
                <a class="nav-link  nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertise"  href="/site/advertise.html"  tabindex="0">
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link   tnt-section-terms-of-use"  href="/site/terms.html"  tabindex="0">
                    <span class="nav-label">Terms of Use</span>
                </a></li><li>
                <a class="nav-link   tnt-section-privacy-policy"  href="/site/privacy.html"  tabindex="0">
                    <span class="nav-label">Privacy Policy</span>
                </a></li><li>
                <a class="nav-link   tnt-section-home-delivery"  href="/site/forms/subscription_services/subscribe/"  tabindex="0">
                    <span class="nav-label">Home Delivery</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/site/forms/"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="/place_an_ad/"  tabindex="0">
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-local-weather"  href="/weather/"  tabindex="0">
                    <span class="nav-label">Local Weather</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-local-news"  href="/news/local/"  tabindex="0">
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-regional"  href="/news/regional/"  tabindex="0">
                    <span class="nav-label">Regional</span>
                </a></li><li>
                <a class="nav-link   tnt-section-state"  href="/news/state/"  tabindex="0">
                    <span class="nav-label">State</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/community/"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-this-week"  href="/community/this_week/"  tabindex="0">
                    <span class="nav-label">This Week</span>
                </a></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/calendar/"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cops-and-courts"  href="/cops_and_courts/"  tabindex="0">
                    <span class="nav-label">Cops and Courts</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-real-estate"  href="/real_estate/"  tabindex="0">
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition/"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-real-estate"  href="/classifieds/housing/sale"  tabindex="0">
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link   tnt-section-property-for-rent"  href="/classifieds/housing/rent"  tabindex="0">
                    <span class="nav-label">Property For Rent</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cars-vehicles"  href="/classifieds/vehicle"  tabindex="0">
                    <span class="nav-label">Cars & Vehicles</span>
                </a></li><li>
                <a class="nav-link   tnt-section-jobs"  href="/classifieds/job"  tabindex="0">
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link   tnt-section-items-for-sale"  href="/classifieds/sale"  tabindex="0">
                    <span class="nav-label">Items For Sale</span>
                </a></li><li>
                <a class="nav-link   tnt-section-pets"  href="/classifieds/sale/pet"  tabindex="0">
                    <span class="nav-label">Pets</span>
                </a></li><li>
                <a class="nav-link   tnt-section-auctions-estate-garage-sales"  href="/classifieds/sale/sale"  tabindex="0">
                    <span class="nav-label">Auctions, Estate & Garage Sales</span>
                </a></li><li>
                <a class="nav-link   tnt-section-services"  href="/classifieds/service"  tabindex="0">
                    <span class="nav-label">Services</span>
                </a></li><li>
                <a class="nav-link   tnt-section-community"  href="/classifieds/community"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link   tnt-section-personals"  href="/classifieds/personals"  tabindex="0">
                    <span class="nav-label">Personals</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="/place_an_ad/"  tabindex="0">
                    <span class="nav-label">Place An Ad</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-valley-view"  href="/valley_view/"  tabindex="0">
                    <span class="nav-label">Valley View</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        <div class="visible-xs pull-right article-share-nav" style="background-color: #ffffff">
            <span>Share This <i class="fas tnt-arrow-right"></i></span>
            <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&via=WdvlWeekly&url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.nwnews.com/tncms/asset/editorial/7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BWoodinville%20Weekly%5D%20Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&body=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
        </div>
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-914271" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"900","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-914272" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" class="asset article-default"  data-url="https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="Editor, "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/977b0d42-992c-11ea-b9dc-7bba8052552d.png">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="nwnews.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" />
    <div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Letter: Trader Joe's joke 'vent' too far
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2021-04-07T15:42:00-06:00" class="tnt-date asset-date text-muted">
            Apr 7, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-04-07T15:42:00-06:00" class="tnt-date asset-date text-muted">18 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-04-07T15:42:00-06:00">
    <meta itemprop="datePublished" content="2021-04-07T15:42:00-06:00">
    <meta itemprop="dateModified" content="2021-04-07T15:42:00-06:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&via=WdvlWeekly&url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.nwnews.com/tncms/asset/editorial/7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BWoodinville%20Weekly%5D%20Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&body=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&via=WdvlWeekly&url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.nwnews.com/tncms/asset/editorial/7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BWoodinville%20Weekly%5D%20Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&body=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7cbe4a58-97f2-11eb-8eaa-03b8e90af65f-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" class="save-list-7cbe4a58-97f2-11eb-8eaa-03b8e90af65f-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                            <script>
                                $(window).load(function() {
                                    window.setTimeout(affixShare, 2000);
                                    function affixShare() {
                                        var sHeight = $('#share-left-affix').outerHeight(true);
                                        var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                        var sTop = $('#share-left-affix').offset().top - 50;
                                        var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + cHeight - 50);
                                        if(cHeight > sHeight) {
                                            $('#share-left-affix').affix({
                                                offset: { top: sTop, bottom: sBottom }
                                            });
                                        }
                                    }
                                });
                                $(window).resize(function() {
                                    var sHeight = $('#share-left-affix').outerHeight(true);
                                    var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                    var sTop = $('#share-left-affix').offset().top - 50;
                                    var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + $('#share-left-affix').parent().outerHeight(true) - 50);
                                    if(cHeight > sHeight) {
                                        $('#share-left-affix').data('bs.affix').options.offset.top = sTop;
                                        $('#share-left-affix').data('bs.affix').options.offset.bottom = sBottom;
                                    }
                                });
                            </script>
                            
                        
                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&via=WdvlWeekly&url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.nwnews.com/tncms/asset/editorial/7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BWoodinville%20Weekly%5D%20Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&body=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7cbe4a58-97f2-11eb-8eaa-03b8e90af65f-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" class="save-list-7cbe4a58-97f2-11eb-8eaa-03b8e90af65f-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p class="p1"><span class="s1"><strong>Editor,</strong></span></p></div><div class="subscriber-preview"><p class="p2"><span class="s1">Hey, I love a good April Fool’s joke as much as the next guy.<span class="Apple-converted-space"> </span> The Green Grapes was especially fun.<span class="Apple-converted-space"> </span> I figured maybe we should.<span class="Apple-converted-space"> </span> The Rocky Ford, CO, high school team is the Fighting Meloneers, as Rocky Ford is the epicenter of cantaloupe and honey dew farming in the U.S.</span></p></div><div class="subscriber-only"><p class="p2"><span class="s1">Using the sports field as a temp dog park probably got a lot of ire up, especially amongst the Jocks in town, but still funny.</span></p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/opinion","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top-asset', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p class="p2"><span class="s1">But the bit about us getting a Trader Joe’s?<span class="Apple-converted-space"> </span> Man, that was bad.<span class="Apple-converted-space"> </span> Impolite.<span class="Apple-converted-space"> </span> Even maybe mean.<span class="Apple-converted-space"> </span> My wife and I did a Happy Dance when we saw the story.<span class="Apple-converted-space"> </span> No more hiking to Totem Hole for our salsa and microwave rice.<span class="Apple-converted-space"> </span></span></p></div><div class="subscriber-only"><p class="p2"><span class="s1">Then I saw the Grapes.<span class="Apple-converted-space"> </span> Talk about a letdown.</span></p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/opinion","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle-asset', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><div class="subscriber-only"><p class="p2"><span class="s1">So yeah, I think y’all “vent" a little too far.<span class="Apple-converted-space"> </span></span></p></div><div class="subscriber-only"><p class="p3"> </p></div><div class="subscriber-only"><p class="p4"><span class="s1"><strong>Richard C Reed</strong></span></p></div><div class="subscriber-only"><p class="p4"><span class="s1"><strong>The Vedge</strong></span></p></div><div class="subscriber-only"><p class="p4"><span class="s1"><strong>Voodinville</strong></span></p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/opinion","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom-asset', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&via=WdvlWeekly&url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.nwnews.com/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.nwnews.com/tncms/asset/editorial/7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BWoodinville%20Weekly%5D%20Letter%3A%20Trader%20Joe%27s%20joke%20%27vent%27%20too%20far&body=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7cbe4a58-97f2-11eb-8eaa-03b8e90af65f"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7cbe4a58-97f2-11eb-8eaa-03b8e90af65f-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" class="save-list-7cbe4a58-97f2-11eb-8eaa-03b8e90af65f-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-948311" class="tncms-block">

<style>
div#promo-button-sign{ margin-left: 22em;}

div#promo-button-subscribe{ margin-left: 22em;}
.custom-btn{
   background: #368740;
    color: #FFF;
    padding-top: 5px;
    padding-bottom: 9px;
    font-size: 18px;
    
}
.custom-btn:hover{
   background: #fff;
    color: #368740;
    
}


</style>


<div class="row">
<div class="col-sm-3">
<div class="not-logged-in">
<!-- displayed when user is not logged in -->
<section id="custom-subcribe" class="block emphasis-h3   ">
<div id="promo-button-sign" class="promo-button">
   <a class="custom-btn-a" href="/users/admin/mailinglist/">
      <button type="button" class="btn  custom-btn ">Sign In  / Up</button>
   </a>
   </div>
   </section>
  </div>
</div>
<div class="logged-in">
<section id="custom-subcribe" class="block emphasis-h3   ">
<div id="promo-button-subscribe" class="promo-button">
<a class="custom-btn-a" href="/users/admin/mailinglist/"><button type="button" class="btn  custom-btn ">Subscribe</button></a></div></section></div>
</div></div><div id="tncms-block-956058" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-leaderboard-articlebottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-articlebottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/opinion/letter-trader-joes-joke-vent-too-far/article_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="7cbe4a58-97f2-11eb-8eaa-03b8e90af65f" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container ">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.nwnews.com/users/login/?referer_url=https%3A%2F%2Fwww.nwnews.com%2Fopinion%2Fletter-trader-joes-joke-vent-too-far%2Farticle_7cbe4a58-97f2-11eb-8eaa-03b8e90af65f.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/opinion","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-914339" class="tncms-block"><section id="block-914339" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-914339 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/site/forms/online_services/letter_editor">
                
                Submit a Letter to the Editor
                
                    </a>
                
            </h3>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>If you're interested in submitting a Letter to the Editor, click here.</p><a href="/site/forms/online_services/letter_editor">
                <button type="button" class="btn btn-primary  ">Submit</button>
            </a></div>
</article></section></div><div id="tncms-block-914290" class="tncms-block visible-lg visible-md"><section id="block-914290" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-914290 ">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=""><ul class="card headline-list bullet-square border border-dashed"><li class="hide-bullets">
            <span class="tnt-headline ">
        
             <a href="/community/pet-of-the-week-sidney/article_ce7a1cf4-97fd-11eb-9cde-63cdadc1f0a7.html" class="tnt-asset-link">
        
        <span class="premium-asset-icon fas tnt-key tnt-fw"></span>

        
            Pet of the Week: Sidney</a></span>
        </li><li class="hide-bullets">
            <span class="tnt-headline ">
        
             <a href="/community/photos-cottage-lake-egg-hunters/article_e19079c6-97fa-11eb-ad0a-5fa28a69aa11.html" class="tnt-asset-link">
        
        <span class="premium-asset-icon fas tnt-key tnt-fw"></span>

        
            PHOTOS: Cottage lake egg hunters</a></span>
        </li><li class="hide-bullets">
            <span class="tnt-headline ">
        
             <a href="/valley_view/fire-chief-mental-health-remains-crucial-for-local-first-responders/article_863b0086-97f6-11eb-8c31-1ba4cf26aa50.html" class="tnt-asset-link">
        
        <span class="premium-asset-icon fas tnt-key tnt-fw"></span>

        
            Fire chief: Mental health remains crucial for local first responders</a></span>
        </li><li class="hide-bullets">
            <span class="tnt-headline ">
        
             <a href="/valley_view/duvall-man-prepares-for-record-breaking-jump/article_b496426e-97f2-11eb-a1af-f3c0f9d44872.html" class="tnt-asset-link">
        
        <span class="premium-asset-icon fas tnt-key tnt-fw"></span>

        
            Duvall man prepares for record-breaking jump</a></span>
        </li><li class="hide-bullets">
            <span class="tnt-headline ">
        
             <a href="/news/bill-kickstarts-effort-for-state-universal-healthcare/article_d838b164-97ef-11eb-a147-dbd395b762c2.html" class="tnt-asset-link">
        
        <span class="premium-asset-icon fas tnt-key tnt-fw"></span>

        
            Bill kickstarts effort for state universal healthcare</a></span>
        </li><li class="hide-bullets">
            <span class="tnt-headline ">
        
             <a href="/news/sweeping-childcare-reform-moving-in-legislature/article_6ee37064-97ef-11eb-ac6a-33500ad544dd.html" class="tnt-asset-link">
        
        <span class="premium-asset-icon fas tnt-key tnt-fw"></span>

        
            Sweeping childcare reform moving in Legislature</a></span>
        </li><li class="hide-bullets">
            <span class="tnt-headline ">
        
             <a href="/sports/local-9-year-old-boy-wins-us-kids-golf-tournament-in-lacey/article_2fd61454-97ee-11eb-be56-ff97abb62558.html" class="tnt-asset-link">
        
        <span class="premium-asset-icon fas tnt-key tnt-fw"></span>

        
            Local 9 year old boy wins US Kids Golf tournament in Lacey</a></span>
        </li><li class="hide-bullets">
            <span class="tnt-headline ">
        
             <a href="/news/library-system-to-reopen-additional-libraries-including-woodinville/article_a557f806-97ed-11eb-bb9b-8bc242ed750f.html" class="tnt-asset-link">
        
        <span class="premium-asset-icon fas tnt-key tnt-fw"></span>

        
            Library system to reopen additional libraries, including Woodinville</a></span>
        </li></ul></div></section></div><div id="tncms-block-914328" class="tncms-block"><section id="block-914328" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-914328 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-914328" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-914328" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-914328" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-914328" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-914328" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/community/trader-joe-s-is-final-add-on-to-woodin-creek-development/article_f591d72c-92fe-11eb-90e8-ef8ac2b1c38c.html">Trader Joe’s is final add-on to Woodin Creek development</a></li><li><a href="/news/woodinville-high-school-to-change-mascot-to-the-green-grapes/article_55673cc8-92ff-11eb-b0d9-bf0dfbf42351.html">Woodinville High School to change mascot to the Green Grapes</a></li><li><a href="/news/a-dog-park-is-coming-to-woodinville/article_2ae2e484-92ff-11eb-978a-bf0da72dad93.html">A dog park is coming to Woodinville</a></li><li><a href="/community/woodinville-resident-to-release-new-book-april-20/article_131d8ec6-97dc-11eb-925b-e7e37f901fee.html">Woodinville resident to release new book April 20</a></li><li><a href="/sports/falcons-defeat-jaguars-on-senior-night/article_3f23ce36-9269-11eb-ae44-c397f84ff33c.html">Falcons defeat Jaguars on senior night</a></li><li><a href="/obituaries/john-daniel-lawson/article_35c405f6-97fd-11eb-b102-5f992434723d.html">John Daniel Lawson</a></li><li><a href="/news/everett-man-dies-in-bothell-car-accident/article_3d86427e-97d8-11eb-a164-db35f71c1fc9.html">Everett man dies in Bothell car accident</a></li><li><a href="/community/pet-of-the-week-sidney/article_ce7a1cf4-97fd-11eb-9cde-63cdadc1f0a7.html">Pet of the Week: Sidney</a></li><li><a href="/valley_view/duvall-man-prepares-for-record-breaking-jump/article_b496426e-97f2-11eb-a1af-f3c0f9d44872.html">Duvall man prepares for record-breaking jump</a></li><li><a href="/sports/local-9-year-old-boy-wins-us-kids-golf-tournament-in-lacey/article_2fd61454-97ee-11eb-be56-ff97abb62558.html">Local 9 year old boy wins US Kids Golf tournament in Lacey</a></li></ul></div>
        
        
            <div id="images-914328" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><p class="no-results text-muted">Sorry, there are no recent results for popular images.</p></div>
        
        <div id="videos-914328" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-914328" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/woodinville-high-school-to-change-mascot-to-the-green-grapes/article_55673cc8-92ff-11eb-b0d9-bf0dfbf42351.html">Woodinville High School to change mascot to the Green Grapes</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-914280" class="tncms-block"></div><div id="tncms-block-914311" class="tncms-block"><section id="block-914311" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-914311 ">
        <div class="block-title-inner">
            <h4>
                
                Online Poll
                
            </h4>
        </div>
    </div></div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/whats-your-favorite-type-of-girl-scout-cookie/poll_5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca.html" class="tnt-asset-link">
        

        
            What's your favorite type of Girl Scout cookie?</a></h4>
            <div id="poll-5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload">
                <div id="poll-5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311-your-vote"></span>
                </div>
                <div id="poll-5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311-results" class="tnt-poll-results hide"></div>
                <div id="poll-5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311-container">
                    <form id="poll-5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311-form" class="tnt-poll-form" role="form" method="post" action="/whats-your-favorite-type-of-girl-scout-cookie/poll_5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Thin Mints" value="C9483BE3-74C0-0001-DE851BC015A01B01"> Thin Mints
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Samoas" value="C9483BE4-B830-0001-B4BB178E1BDF1D61"> Samoas
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Tagalongs" value="C9483BE5-BA40-0001-5E1FE32051D01CC1"> Tagalongs
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="S'mores" value="C9483BE7-8120-0001-CC5D99D09EA01B6E"> S'mores
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Trefoils" value="C9483BEB-6A70-0001-8FD8C0452F0045D0"> Trefoils
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Do-si-dos" value="C9483BF3-BFB0-0001-E98C26FA2E8C12D0"> Do-si-dos
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Toffee-tastic (the gluten free one)" value="C9483C06-C700-0001-E2E01FCD1850DF00"> Toffee-tastic (the gluten free one)
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="I don't like Girl Scout cookies but sometimes still buy them because it's hard to say no to those cute kids." value="C9483C0A-6CC0-0001-C1F61BDD168B6A20"> I don't like Girl Scout cookies but sometimes still buy them because it's hard to say no to those cute kids.
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="I don't eat cookies" value="C9483C29-0BF0-0001-66431D9713E916D8"> I don't eat cookies
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311-back-vote" class="padding-top hide">
                <button id="poll-5b9b3d28-81f8-11eb-a5cb-53fd997fc4ca-914311-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/opinion","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-914348" class="tncms-block"></div><div id="tncms-block-914307" class="tncms-block"><section id="block-914307" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-914307 ">
        <div class="block-title-inner">
            <h3>
                
                Newspaper Ads
                
            </h3>
        </div>
    </div></div>
    
    <div class="masonry grid-cols-2" data-grid-cols="2">
        
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/lawn/tree/progression-tree-care/pdfdisplayad_bd6ddffc-f9cb-11ea-9f81-bb2122fed3b6.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="Progression Tree Care"><span class="title">Progression Tree Care</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Progression Tree Care"
                            class="img-responsive lazyload full default"
                            width="260"
                            height="600"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/b/d6/bd6ddffc-f9cb-11ea-9f81-bb2122fed3b6/5f64dfc4bbd4c.preview.jpg?resize=150%2C346 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/b/d6/bd6ddffc-f9cb-11ea-9f81-bb2122fed3b6/5f64dfc4bbd4c.preview.jpg?resize=200%2C462 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/b/d6/bd6ddffc-f9cb-11ea-9f81-bb2122fed3b6/5f64dfc4bbd4c.preview.jpg?resize=225%2C519 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/b/d6/bd6ddffc-f9cb-11ea-9f81-bb2122fed3b6/5f64dfc4bbd4c.preview.jpg?resize=260%2C600 300w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/lawn/landscape/apols-landscape-maintenance/pdfdisplayad_45c0f018-f938-11ea-8448-af3901545bc1.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="APOL'S LANDSCAPE MAINTENANCE"><span class="title">APOL'S LANDSCAPE MAINTENANCE</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="APOL'S LANDSCAPE MAINTENANCE"
                            class="img-responsive lazyload full default"
                            width="284"
                            height="510"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/4/5c/45c0f018-f938-11ea-8448-af3901545bc1/5f63e85b8dcf8.preview.jpg?resize=150%2C269 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/4/5c/45c0f018-f938-11ea-8448-af3901545bc1/5f63e85b8dcf8.preview.jpg?resize=200%2C359 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/4/5c/45c0f018-f938-11ea-8448-af3901545bc1/5f63e85b8dcf8.preview.jpg?resize=225%2C404 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/4/5c/45c0f018-f938-11ea-8448-af3901545bc1/5f63e85b8dcf8.preview.jpg?resize=284%2C510 300w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/education/tutor/brocks-academy/pdfdisplayad_18ec4f02-f9e6-11ea-9efb-537ecbfb9d38.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="Brock's Academy"><span class="title">Brock's Academy</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-horizontal ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Brock's Academy"
                            class="img-responsive lazyload full default"
                            width="292"
                            height="216"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/1/8e/18ec4f02-f9e6-11ea-9efb-537ecbfb9d38/5f650bfcb9b28.preview.jpg?resize=150%2C111 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/1/8e/18ec4f02-f9e6-11ea-9efb-537ecbfb9d38/5f650bfcb9b28.preview.jpg?resize=200%2C148 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/1/8e/18ec4f02-f9e6-11ea-9efb-537ecbfb9d38/5f650bfcb9b28.preview.jpg?resize=225%2C166 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/1/8e/18ec4f02-f9e6-11ea-9efb-537ecbfb9d38/5f650bfcb9b28.preview.jpg?resize=292%2C216 300w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/lawn/teds-sheds/pdfdisplayad_9deb37ea-f9e6-11ea-9fe4-bfcff68ff085.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="Ted's Sheds"><span class="title">Ted's Sheds</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Ted's Sheds"
                            class="img-responsive lazyload full default"
                            width="302"
                            height="515"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/9/de/9deb37ea-f9e6-11ea-9fe4-bfcff68ff085/5f650cdc13635.preview.jpg?resize=150%2C256 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/9/de/9deb37ea-f9e6-11ea-9fe4-bfcff68ff085/5f650cdc13635.preview.jpg?resize=200%2C341 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/9/de/9deb37ea-f9e6-11ea-9fe4-bfcff68ff085/5f650cdc13635.preview.jpg?resize=225%2C384 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/9/de/9deb37ea-f9e6-11ea-9fe4-bfcff68ff085/5f650cdc13635.preview.jpg?resize=300%2C512 300w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/9/de/9deb37ea-f9e6-11ea-9fe4-bfcff68ff085/5f650cdc13635.preview.jpg?resize=302%2C515 400w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/home/roof/aaa1-roof-care/pdfdisplayad_5f2a36be-f9e6-11ea-bca0-139cdbf3482d.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="AAA1 Roof Care"><span class="title">AAA1 Roof Care</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="AAA1 Roof Care"
                            class="img-responsive lazyload full default"
                            width="281"
                            height="321"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/5/f2/5f2a36be-f9e6-11ea-bca0-139cdbf3482d/5f650c728b09a.preview.jpg?resize=150%2C171 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/5/f2/5f2a36be-f9e6-11ea-bca0-139cdbf3482d/5f650c728b09a.preview.jpg?resize=200%2C228 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/5/f2/5f2a36be-f9e6-11ea-bca0-139cdbf3482d/5f650c728b09a.preview.jpg?resize=225%2C257 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/5/f2/5f2a36be-f9e6-11ea-bca0-139cdbf3482d/5f650c728b09a.preview.jpg?resize=281%2C321 300w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/home/construction/doug-wetter-construction/pdfdisplayad_f271536c-f9c3-11ea-9122-abda5e153c44.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="Doug Wetter Construction"><span class="title">Doug Wetter Construction</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Doug Wetter Construction"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="400"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/f/27/f271536c-f9c3-11ea-9122-abda5e153c44/5f64d2b155a9f.preview.jpg?resize=150%2C200 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/f/27/f271536c-f9c3-11ea-9122-abda5e153c44/5f64d2b155a9f.preview.jpg?resize=200%2C267 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/f/27/f271536c-f9c3-11ea-9122-abda5e153c44/5f64d2b155a9f.preview.jpg?resize=225%2C300 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/f/27/f271536c-f9c3-11ea-9122-abda5e153c44/5f64d2b155a9f.preview.jpg?resize=300%2C400 300w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/tech/computer/lcs-network-consulting/pdfdisplayad_320284c4-f9c4-11ea-8a6c-5f45178382a7.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="LCS Network Consulting"><span class="title">LCS Network Consulting</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-horizontal ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="LCS Network Consulting"
                            class="img-responsive lazyload full default"
                            width="286"
                            height="265"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/3/20/320284c4-f9c4-11ea-8a6c-5f45178382a7/5f64d31bde2c3.preview.jpg?resize=150%2C139 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/3/20/320284c4-f9c4-11ea-8a6c-5f45178382a7/5f64d31bde2c3.preview.jpg?resize=200%2C185 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/3/20/320284c4-f9c4-11ea-8a6c-5f45178382a7/5f64d31bde2c3.preview.jpg?resize=225%2C208 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/3/20/320284c4-f9c4-11ea-8a6c-5f45178382a7/5f64d31bde2c3.preview.jpg?resize=286%2C265 300w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/home/construction/remodel/highlander-nw/pdfdisplayad_ae3690b2-f9c4-11ea-99ca-7b5aaee6a04b.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="Highlander NW"><span class="title">Highlander NW</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Highlander NW"
                            class="img-responsive lazyload full default"
                            width="272"
                            height="298"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/a/e3/ae3690b2-f9c4-11ea-99ca-7b5aaee6a04b/5f64d3ec4ad7e.preview.jpg?resize=150%2C164 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/a/e3/ae3690b2-f9c4-11ea-99ca-7b5aaee6a04b/5f64d3ec4ad7e.preview.jpg?resize=200%2C219 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/a/e3/ae3690b2-f9c4-11ea-99ca-7b5aaee6a04b/5f64d3ec4ad7e.preview.jpg?resize=225%2C247 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/a/e3/ae3690b2-f9c4-11ea-99ca-7b5aaee6a04b/5f64d3ec4ad7e.preview.jpg?resize=272%2C298 300w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/home/construction/catalyst-construction-inc/pdfdisplayad_3aba2c46-f9c6-11ea-bb6a-1753dd44d626.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="Catalyst Construction Inc."><span class="title">Catalyst Construction Inc.</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-horizontal ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Catalyst Construction Inc."
                            class="img-responsive lazyload full default"
                            width="283"
                            height="222"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/3/ab/3aba2c46-f9c6-11ea-bb6a-1753dd44d626/5f64d68584209.preview.jpg?resize=150%2C118 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/3/ab/3aba2c46-f9c6-11ea-bb6a-1753dd44d626/5f64d68584209.preview.jpg?resize=200%2C157 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/3/ab/3aba2c46-f9c6-11ea-bb6a-1753dd44d626/5f64d68584209.preview.jpg?resize=225%2C177 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/3/ab/3aba2c46-f9c6-11ea-bb6a-1753dd44d626/5f64d68584209.preview.jpg?resize=283%2C222 300w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.nwnews.com/classifieds/service/home/roof/gutters-inc/pdfdisplayad_a7b02b66-f9c6-11ea-8519-6b3533ccf2ba.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-914307" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'   data-title="Gutters Inc."><span class="title">Gutters Inc.</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-horizontal ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Gutters Inc."
                            class="img-responsive lazyload full default"
                            width="283"
                            height="260"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/a/7b/a7b02b66-f9c6-11ea-8519-6b3533ccf2ba/5f64d73c677f8.preview.jpg?resize=150%2C138 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/a/7b/a7b02b66-f9c6-11ea-8519-6b3533ccf2ba/5f64d73c677f8.preview.jpg?resize=200%2C184 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/a/7b/a7b02b66-f9c6-11ea-8519-6b3533ccf2ba/5f64d73c677f8.preview.jpg?resize=225%2C207 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/assets/v3/classifieds/a/7b/a7b02b66-f9c6-11ea-8519-6b3533ccf2ba/5f64d73c677f8.preview.jpg?resize=283%2C260 300w" />
                
                
            </div>
            
        </figure>
                    </div>
          </div></div>
    <div class="modal bulletins-modal" id="bulletins-modal-914307" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><i aria-hidden="true" class="fas tnt-times"></i></button>
                    <h4 class="modal-title" id="myModalLabel">Bulletin</h4>
                </div>
                <div class="modal-body">
                    <iframe title="bulletins-iframe"></iframe>
                </div>
            </div>
        </div>
    </div>
     
    <div class="clearfix"></div>
    </section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/opinion","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-914273" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-914274" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-914351" class="tncms-block"><section id="block-914351" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-914351 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news"  href="/news"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-community"  href="/community/"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link   tnt-section-announcements"  href="/announcements/"  tabindex="0">
                    <span class="nav-label">Announcements</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/tributes/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/opinion"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-multimedia"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Multimedia</span>
                </a></li><li>
                <a class="nav-link   tnt-section-online-features"  href="/online_features"  tabindex="0">
                    <span class="nav-label">Online Features</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-914319" class="tncms-block"><section id="block-914319" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-914319 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-subscription-services"  href="/site/forms/subscription_services"  tabindex="0">
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/site/forms"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="/place_an_ad/"  tabindex="0">
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-email-alerts"  href="/users/admin/mailinglist"  tabindex="0">
                    <span class="nav-label">Email Alerts</span>
                </a></li><li>
                <a class="nav-link   tnt-section-search"  href="/search"  tabindex="0">
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-914356" class="tncms-block padding-bottom"><div id="site-logo-914356" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/ad8d9714-d11a-11ea-bfc9-3b5273e8fa00.png?resize=200%2C46" 
            srcset="https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/ad8d9714-d11a-11ea-bfc9-3b5273e8fa00.png?resize=150%2C35 150w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/ad8d9714-d11a-11ea-bfc9-3b5273e8fa00.png?resize=200%2C46 200w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/ad8d9714-d11a-11ea-bfc9-3b5273e8fa00.png?resize=225%2C52 225w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/ad8d9714-d11a-11ea-bfc9-3b5273e8fa00.png?resize=300%2C70 300w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/ad8d9714-d11a-11ea-bfc9-3b5273e8fa00.png?resize=400%2C93 400w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/ad8d9714-d11a-11ea-bfc9-3b5273e8fa00.png?resize=540%2C125 540w, https://bloximages.newyork1.vip.townnews.com/nwnews.com/content/tncms/custom/image/ad8d9714-d11a-11ea-bfc9-3b5273e8fa00.png 640w"
            sizes="(min-width: 1200px) 380px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="560"
            height="130"
            alt="site-logo"></a>
        </div></div></div><div id="tncms-block-914353" class="tncms-block"><section id="block-914353" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-914353 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>nwnews.com</strong><br>
    PO Box 587<br>
    Woodinville, WA 98072
    <br>
    
        <strong>Phone:</strong> 1-425-483-0606<br>
        <strong>Email:</strong> <a href="mailto:sales@woodinville.com">sales@woodinville.com</a><br>
    
</address></section></div><div id="tncms-block-914361" class="tncms-block padding-bottom"><div class="follow-links-914361 default">
    
    <section id="block-914361" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-914361 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/wdvlweekly/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/WdvlWeekly" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.linkedin.com/showcase/woodinvilleweekly/" title="LinkedIn" target="_blank" rel="noopener" class="btn btn-md btn-link li" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-linkedin-in"></i>
                    <span class="sr-only">LinkedIn</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.nwnews.com",
  "sameAs" : ["https://www.facebook.com/wdvlweekly/","https://twitter.com/WdvlWeekly","https://www.linkedin.com/showcase/woodinvilleweekly/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-914323" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-914323"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">Woodinville Weekly</a>, PO Box 587 Woodinville, WA</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/nwnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/opinion","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-impact-bottom" class="tncms-region-ads">

<div id="blox-ad-position-fixed-impact-bottom1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-impact-bottom', slot: 1, fold: "below"});</script>

</div>
</div>

    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("7cbe4a58-97f2-11eb-8eaa-03b8e90af65f")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.c1fd4b9015c14b57a58acdbc3ee4daca.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ function articleShareSticky(){
                setTimeout(function(){
                    var sMainTop = document.querySelector('#main-body-container').offsetTop,
                        oNavBar = document.querySelector('#site-navbar-container');
                    if (sMainTop < window.scrollY){
                        oNavBar.classList.add('article-share')
                    } else {
                        oNavBar.classList.remove('article-share')
                    }
                }, 150)
            }
            document.addEventListener('scroll', articleShareSticky); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.aa4a56a35da582e986ed8bbce2004ea4.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/nwnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/bulletins.29b98144dea96166607cf028fe68b7e2.js"></script></body>
</html>